Recently I’ve had a problem in Internet Explorer where Google Maps doesn’t load fully, get broken images and the “still loading…slow” message  appears when trying to use Google Maps as per screenshot below:



All other browsers work fine, just Internet Explorer and more recently, with Windows 7.

Here are some possible solutions to try:

  1. The easiest thing to try is to right mouse click on the Internet Explorer icon and select “Run as administrator“.

    You also need to open up ALL the localised version of Google Maps you want to use. As soon as I open Internet Explorer with the “Run as administrator” option, then go to http://maps.google.com – everything opened up fine, I can browse the maps properly without any broken images. However, if I don’t “Run as administrator” in IE and then open http://maps.google.co.nz instead, I get broken images and the maps don’t open correctly.  But as soon as I select “Run as administrator” in IE and then go to http://maps.google.co.nz, then the site loads up fine.

  2. Another solution is to Uninstall Java, reboot the machine then reinstall the latest version of Java. After you reinstall Java, right mouse click on the Internet Explorer icon and select “Run as administrator” to launch IE – this is really important 

  3. Another solution is to Reset Internet Explorer settings by going into Internet Options –> [Advanced] tab then click on the [Reset] button at the bottom. After that, remember to right mouse click on the Internet Explorer icon and select “Run as administrator“.
  4. Fourth solution is to Empty Internet Explorer settings by going into Internet Options –> [General] tab –> click on [Delete] button –> clear tick in “Preserve Favorites website data” –> then press [Delete] button. After that, remember to right mouse click on the Internet Explorer icon and select “Run as administrator“.


Hope that helps.

Would like to know your feedback whether this fixes your problem or whether there are other solutions to also use or add.

GD Star Rating
loading...
GD Star Rating
loading...
Fix - Google Maps "still loading....slow?" message in Internet Explorer, 1.0 out of 5 based on 1 rating

Related Posts:

  • No Related Posts